News and Updates on the Rigs of Rods truck simulator, based on an advanced soft-body physics engine.

Sunday, March 11, 2007

Version 0.31 is ready!

Finally, the much awaited version 0.31 is ready for download.
It includes many goodies:
  • Boats, with a small wahoo, a Class 1 speedboat contributed by cdquicksilver, and a very large high sea tug, the Smit Rotterdam, that has a rollable platform.
  • A new terrain, called "island", that is still under construction but that will soon replace the two classic RoR terrains, because they are not realistic islands.
  • Infinite sea with waves. Take the Smit and sail far from the island: you will encounter high swells offshore. You can even configure the wave fields (see the data\wavefield.cfg file).
  • A separate configurator program. Now you must start the RoRconfig program first, to choose your configuration options, save them, then start RoR. This configurator adds more joystick configuration options.
  • An experimental shift stick mode that uses a force feedback joystick to simulate the grid of the gearbox. (see the readme)
  • Serious bugfixing: camera shaking has been dramatically reduced, and the "crash on plane crash" problem is mostly eliminated.
  • Addition of the Challenger car contributed by hemicuda.
There are still many rough edges in this version. Boat dashboard, propulsion and rudder systems are very crude, there are many things to do to complete the Island terrain, there is no joystick buttons and keys configuration yet, and some vehicles needs upgrades, not to mention some very good vehicles on the repository that should be integrated, and trucks file management needs also a general overhaul. Oh, and I forget I did not do a car ferry!!!
Remember that all this is a hobby for me, and my free time is very limited so be patient.

I'm also searching for a good, pro bono, 3D artist to help me to overhaul scenery objects (to design a master texture and model small cities and villages) contact: pricorde-at-rigsofrods.com.

Enjoy!

Edit: The RoRconfig configurator crashes when no joystick is present. You can try to replace it with this fixed version. Comment here how it works, I'll add it to the official package tomorrow (have to go to bed!).

30 Comments:

Blogger werner said...

wow this is the best news of the year
thanks for it

11/3/07 21:17

 
Blogger ZPGamez said...

Looks Great pricorde.

11/3/07 21:22

 
Blogger werner said...

tham can't get it to run
everythime the rorconfig.exe shut down

11/3/07 21:25

 
Blogger pricorde said...

Please report any problems here.

11/3/07 22:22

 
Blogger c--b said...

Rorconfig.exe crashes on startup, also if you add in the ror.cfg and ogre.cfg files from 0.30 to the 0.31 folder the game works, to an extent. Once I got into the game using that method I found that boats cannot be loaded from the garage without the game crashing, the same happens when you approach the boat on the shore in the Island level.

On a separate note, if you drive a car out to sea (The AE86 in my case) it's not effected by the giant waves, and drives as if it's on an infinite flat plane.

Also, I'm interested in making buildings for you pricorde, I was contemplating doing it before you posted the request and had also already started on some new roads.

11/3/07 22:52

 
Blogger pricorde said...

Dang!
Does rorconfig starts if you put the old 0.30 ror.cfg and ogre.cfg in the 0.31 folder?

Are there any error messages?

Can you post the end of the ogre.log file generated after a rorconfig crash ?

(c--b, send me an email so we can talk about buildings)

11/3/07 23:04

 
Blogger c--b said...

Well, I just tried running vccrt.msi again, and suddenly the boats don't cause the game to crash. Also, the Wahoo drives around in circles, I can't seem to go in a straight line :P

rorconfig.exe still won't work though.

11/3/07 23:07

 
Blogger tuusita said...

maybe the boat problem is because you don't have controls for the boat set up (since rorconfig didn't work)?

11/3/07 23:11

 
Blogger tuusita said...

my ogre.cfg:
----------------

Render System=Direct3D9 Rendering Subsystem

[Direct3D9 Rendering Subsystem]
Allow NVPerfHUD=No
Anti aliasing=NonMaskable 5
Floating-point mode=Fastest
Full Screen=Yes
Rendering Device=NVIDIA GeForce 8800 GTX
VSync=Yes
Video Mode=1280 x 1024 @ 32-bit colour

11/3/07 23:14

 
Blogger tuusita said...

my ror.cfg part I:
--------------------
Texture Filtering Anisotropic (best looking)
Sky effects Sandstorm (fastest)
Shadow technique Stencil shadows (best looking)
Water effects Reflection + refraction (quality optimized)
Engine smoke No
Dust Yes
Spray Yes
Dashboard Yes
Mirrors Yes
Sunburn No
Bloom No
Motion blur No
3D Sound renderer Software (stereo)
Threads 2 (Hyper-Threading or Dual core CPU)

11/3/07 23:15

 
Blogger tuusita said...

my ror.cfg part II:
-----------------
Joy Car Func Vehicle steering Microsoft SideWinder Force Feedback Pro/X-akseli
Joy Car Lin Vehicle steering No
Joy Car Rev Vehicle steering No
Joy Car Hlf Vehicle steering No
Joy Pln Func Hydro F1/F2 Microsoft SideWinder Force Feedback Pro/X-akseli
Joy Pln Lin Hydro F1/F2 Yes
Joy Pln Rev Hydro F1/F2 Yes
Joy Pln Hlf Hydro F1/F2 No
Joy Bot Func Boat rudder Microsoft SideWinder Force Feedback Pro/X-akseli
Joy Bot Lin Boat rudder No
Joy Bot Rev Boat rudder No
Joy Bot Hlf Boat rudder No
Joy Pln Func Hydro F3/F4 Microsoft SideWinder Force Feedback Pro/Y-akseli
Joy Pln Lin Hydro F3/F4 Yes
Joy Pln Rev Hydro F3/F4 No
Joy Pln Hlf Hydro F3/F4 No
Joy Bot Func Boat engine Microsoft SideWinder Force Feedback Pro/Y-akseli
Joy Bot Lin Boat engine No
Joy Bot Rev Boat engine No
Joy Bot Hlf Boat engine No
Joy Pln Func Aircraft elevators Microsoft SideWinder Force Feedback Pro/Kaasu
Joy Pln Lin Aircraft elevators No
Joy Pln Rev Aircraft elevators No
Joy Pln Hlf Aircraft elevators No
Joy Bot Func Boat bow thruster Microsoft SideWinder Force Feedback Pro/Sivuperäsin
Joy Bot Lin Boat bow thruster No
Joy Bot Rev Boat bow thruster No
Joy Bot Hlf Boat bow thruster No
Joy Car Func Vehicle throtle only Microsoft SideWinder Force Feedback Wheel (USB)/Y-akseli
Joy Car Lin Vehicle throtle only No
Joy Car Rev Vehicle throtle only No
Joy Car Hlf Vehicle throtle only No
Joy Pln Func Aircraft rudder Microsoft SideWinder Force Feedback Wheel (USB)/Y-akseli
Joy Pln Lin Aircraft rudder No
Joy Pln Rev Aircraft rudder No
Joy Pln Hlf Aircraft rudder No
Joy Car Func Vehicle brake only Microsoft SideWinder Force Feedback Wheel (USB)/Z-kierto
Joy Car Lin Vehicle brake only No
Joy Car Rev Vehicle brake only Yes
Joy Car Hlf Vehicle brake only Yes

11/3/07 23:15

 
Blogger tuusita said...

That's it for the ror.cfg file.
Obviously you may not have the same controllers so you need to change them. Try using the 0.30 for the controls names...

11/3/07 23:18

 
Blogger werner said...

thanks tuusita get whay better fps from 140 to 220fps normal and on load 60-100fps (only i have no water whit it)

is it posible to fly whit the plane around the map island
because when i whas near the end of the map i fly to a invisible whal (also a test if the there is stil crash on plane crash ) and there is not anymore

11/3/07 23:40

 
Blogger tuusita said...

This is the end of ogre.log from Donken after his rorconfig crashes. That was BEFORE he got/made the cfg files.
----------
.
.
.
Error #: 8
Function: ConfigFile::load
Description: 'ogre.cfg' file not found!.
File: ..\src\OgreConfigFile.cpp
Line: 80
Stack unwinding: beginning of stack

---------end of file

With the cfg files the rorconfig just crashes with Windows saying "rorconfig had a problem and must be shutdown bla bla bla" and ogre.log ends with:
-----------
.
.
.
22:37:45: *-*-* OGRE Initialising
22:37:45: *-*-* Version 1.2.3 (Dagon)
22:37:45: D3D9 : RenderSystem Option: Allow NVPerfHUD = No
22:37:45: D3D9 : RenderSystem Option: Anti aliasing = None
22:37:45: D3D9 : RenderSystem Option: Floating-point mode = Fastest
22:37:45: D3D9 : RenderSystem Option: Full Screen = Yes
22:37:45: D3D9 : RenderSystem Option: Rendering Device = Radeon X1900 Series
22:37:45: D3D9 : RenderSystem Option: VSync = No
22:37:45: D3D9 : RenderSystem Option: Video Mode = 1280 x 960 @ 32-bit colour
-----------end of file


NOTE: for me the rorconfig works ok, those log snippets are from Donken.

11/3/07 23:51

 
Blogger pricorde said...

A few notes:
-boats crashing when activated is really weird
-cars not moving with waves is normal (its an optimization)
-vccrt.msi is the same as usual, you do not need to run it if you had 0.30 running
-invisible wall in the sky? that's impossible

Going toward the FIX:
I made a verbose debug rorconfig.
-Get it at http://pricorde.free.fr/ror/rc/rorconfigdebug.zip
-Replace rorconfig.exe with the new one
-Delete ogre.cfg, and create an empty RoR.cfg file
-Launch rorconfig (and watch it crashing)
-open configlog.txt and post its content here. Also tell what is your Operating system and how many joysticks you have (and how many axises)

I'll try to locate the problem ASAP tomorrow. Sorry for the bug...

12/3/07 00:15

 
Blogger c--b said...

The contents of configlog.txt after RoRconfig.exe crashes:

Log created
Creating dialog
Loading bitmap
Opening joysticks
INTERFACE SETUP BEGIN
INTERFACE SETUP END
Creating Ogre root
Root restore config
Enforcing rendering subsystem
Setting default values
Update Ogre Params Started
Update Ogre Params Finished
Loading config
Update Ogre Params Started
Update Ogre Params Finished
Loading RoR.cfg
Joy ugly code

12/3/07 00:19

 
Blogger tdev said...

same error here, it works when i attach a joystik or pad. but the error can be reproduced when no joystik is attached to the computer

12/3/07 00:29

 
Blogger werner said...

the crash is when i go strait when i have started the engine
i have no water mayby that i why it does do it

12/3/07 00:33

 
Blogger tuusita said...

Maybe rorconfig doesn't work for people WITHOUT a controller plugged in?


Ok, so I have 2 controllers, a joystick and a wheel (both from Microsoft)

--------
Log created
Creating dialog
Loading bitmap
Opening joysticks
INTERFACE SETUP BEGIN
Microsoft SideWinder Force Feedback Pro/X-akseli
Microsoft SideWinder Force Feedback Pro/Y-akseli
Microsoft SideWinder Force Feedback Pro/Kaasu
Microsoft SideWinder Force Feedback Pro/Sivuperäsin
Microsoft SideWinder Force Feedback Wheel (USB)/X-akseli
Microsoft SideWinder Force Feedback Wheel (USB)/Y-akseli
Microsoft SideWinder Force Feedback Wheel (USB)/Z-kierto
INTERFACE SETUP END
Creating Ogre root
Root restore config
Enforcing rendering subsystem
Setting default values
Update Ogre Params Started
Update Ogre Params Finished
Loading config
Update Ogre Params Started
Update Ogre Params Finished
Loading RoR.cfg

12/3/07 00:37

 
Blogger tdev said...

detach the controllers and try out for yourself :)

12/3/07 00:40

 
Blogger tuusita said...

Tested without controllers attached and got the same result than c--b.
With at least one controller it works.

It's good that now it seems we've found the cause of the problem so Pricorde can fix it. =)

Oh and I noticed that if you make an empty file called ror.cfg the debug rorconfig will write to configlog.txt:
------
Log created
Creating dialog
Loading bitmap
Opening joysticks
INTERFACE SETUP BEGIN
Microsoft SideWinder Force Feedback Pro/X-akseli
Microsoft SideWinder Force Feedback Pro/Y-akseli
Microsoft SideWinder Force Feedback Pro/Kaasu
Microsoft SideWinder Force Feedback Pro/Sivuperäsin
INTERFACE SETUP END
Creating Ogre root
Root restore config
Enforcing rendering subsystem
Setting default values
Update Ogre Params Started
Update Ogre Params Finished
Loading config
Update Ogre Params Started
Update Ogre Params Finished
Loading RoR.cfg
Joy ugly code
Showing dialog
App ready
-------

Notice that if you don't have a ror.cfg file the last 3 lines seen above will not show.

12/3/07 00:54

 
Blogger pricorde said...

> detach the controllers and try out for yourself :)

You got it. I fixed this problem (see the post update). Thanks for your help!

12/3/07 01:20

 
Blogger tuusita said...

I'm just happy I did my part. :)

Btw, is there still only one axis for hydros or can I define more? Just wondering about the 'Hydro F1-F2', etc rows in rorconfig. I could really use more hydro axis' in my RoR-copter. I'm already using commands with joystick but in my case it lacks the precision/speed of a hydro. :)

Cheers :)
tuusita

12/3/07 01:53

 
Blogger Diesel_Fuel_Only said...

I've got a bug going here...

I have a Saitek Cyborg 3D USB joystick.

The bug seems to be in the configurator. Under the joysticks tab, the top axis is the forward/backward axis on the joystick. So I set that Throttle + Brake. The next axis down is the steering axis. When I set that one as Steering, the setting above (Throttle + Brake) goes back to none. Its the same if I configure the steering axis first, just vice versa.

Anyone else have this problem?

12/3/07 01:55

 
Blogger tuusita said...

You're right!

I have 2 controllers,
first (joystick) one has 4 axis,
in RoRconfig they show in this order(top-down): X,Y,throttle,twist
It doesn't matter what I select in either X or Y, the other one of those two always goes to 'None'. Even if I select 'None' for X-axis, the Y-axis goes to 'None'.

The second controller (wheel) has 3 axis,
they show below the joystick's axis' in this order: X,Y,twist. Same problem here; whatever I select for either X or Y, the other one goes to 'None'.

Looks to me like it's a bug handling the first two axis' for each controller connected to the computer...

12/3/07 02:10

 
Blogger tuusita said...

You can probably go around it by editing the cfg file manually...

12/3/07 02:11

 
Blogger Diesel_Fuel_Only said...

Yep thats what I ended up doing. Works fine now though. Now its time for me to see if I can load some nodes on the flatbed trailer to keep it under water the its "boat ramp adventure time" :).

"The wind in the wires made a tattletale sound as a wave broke over the railing..."

12/3/07 02:33

 
Blogger dinsterzz said...

lol love the game (havent tested yet but no need to test to know its great :D)
everytime u make us wait the game gets so much better!
i wonder how ror would evolve if we would wait a year for a next release :p

12/3/07 18:28

 
Blogger Bruno said...

Any plans on the Linux version? :D

12/3/07 23:59

 
Blogger Sieg said...

Hey

Great game, been playing it for some time now.
I have found some bugs:
No sound option:
When i choose no sound in the rorconfig.exe and runs the game there is still sound.
Dashboard:
When I have been in a boat and press "r" to get to the rescue car, the dashboard in the bottom of the screen still display to boat controller and the spedometer from the boat.

//Sieg

28/3/07 18:57

 

Post a Comment

<< Home