News and Updates on the Rigs of Rods truck simulator, based on an advanced soft-body physics engine.

Monday, February 16, 2009

Rigs of Rods 0.36 is out!

Finally after almost 11 months!
This release was pretty hard to finish to say the least. I hope you will enjoy the hard work.
It includes many new vehicles and terrains. Some are still in beta state and I thank their authors for allowing me to include them in the release. I hope they will forgive me for the occasional bugs and broken taillights that may arise from the rushed release process. I hope these brilliant vehicles and terrains will encourage more creations for the game.

The new features are numerous, the most visible are:
  • Environment map effects (chrome effects)
  • Shader support (with damage map)
  • Completely new ground friction physics: now more realistic than ever
  • Custom sounds
  • Better support of flexbodies
  • New user interface
  • Files reorganization : now all the files you need to access are in your "My Documents\Rigs of Rods" directory - no more in the Program Files directory.
  • And much more...

Thanks to all the people that helped to the realization of this version.
Special thanks for Box5diesel, Lifter and Sneer for their prolific and very high quality work.
Thanks to Thomas for his very hard work helping me pushing this release.
Thanks to all the donators, volunteers and moderators of the forums.

Note that from now on, the releases will be hosted on sourceforge :
https://sourceforge.net/project/showfiles.php?group_id=252198

Enjoy!

32 Comments:

Blogger Josh said...

Thanks Pricorde! Wish I could play though, I keep getting error 6 when I start the game. Perhaps something is missing in the installation package?

16/2/09 19:56

 
Blogger Jake said...

Pierre, Thanks so much! It's great to finally get a new release! Might I ask when we can expect a Mac version?

16/2/09 19:59

 
Blogger MikeNL said...

finally!

thank you so much!

16/2/09 20:25

 
Blogger Chetic said...

Epic! Thank you so much Pricorde!
You wouldn't beleive the joy I felt when I heard about this. Hah!

16/2/09 20:41

 
Blogger Jardra said...

so, we are leaving the rods and aiming to make all flexmesh now? maybe find a new name for the game, then.

16/2/09 21:52

 
Blogger =Tristan= said...

I'm having a similar problem as Josh. If i try to load any map other than Baker's Farm, i get error 6. This is a right out of the box install. Hope you track down the problem.

16/2/09 22:51

 
Blogger =Tristan= said...

Also, great work from what I've seen on Baker's Farm. Sorry for double post.

16/2/09 22:52

 
Blogger Raphael said...

Oh man! That´s wonderful news for week! Thank you very much! Wish you the best!

17/2/09 00:47

 
Blogger Josh said...

Yeah, so far I'm only able to open
Grendenoble and Baker's Farm, but what I have seen on those maps is amazing! Excellent job :D

Is anyone else having this issue?

17/2/09 05:05

 
Blogger HiddenMyst said...

I donated about a month ago. I almost feel like this is a reward.

17/2/09 07:13

 
Blogger Chetic said...

I had the same problem as the people that can only load Grenoble and Baker's Farm.

I downloaded the install again and reinstalled and that fixed it.

17/2/09 10:54

 
Blogger Sean said...

Excellent, thanks so much team.

17/2/09 18:42

 
Blogger Will said...

I cant even start the game!!

Can anybody help me?

It says that "the application is not configured correctly, and will not run. reinstalling the application may fix this problem." I've installed and reinstalled and even re downloaded it like 12 times.

17/2/09 20:36

 
Blogger =Tristan= said...

I tried the solution that worked for Chetic. It didn't work, still can only play Grenoble and Baker's Farm. I do like Baker's Farm though. Wouldn't mind being able to use N. Helens again.

18/2/09 02:18

 
Blogger Josh said...

This comment has been removed by the author.

18/2/09 03:05

 
Blogger Josh said...

For whoever's having the map loading problem, I think I must've missed something on the wiki until just now - try turning off the vegetation for 0.36 - worked just fine for me.

18/2/09 03:39

 
Blogger Tin said...

I have the same problem like Will. I really wanna play the game!!! please help me:-( ;sorry for my english im from Croatia and im not so good at it:-(

18/2/09 15:59

 
Blogger Thomas said...

please wait, we will release a patch release in some days

18/2/09 19:55

 
Blogger Force India said...

Hi, I'm spanish. Have a blog and I would like you visit the blog, please. I sorry for my English. Rigs of Rods is marvellous, and beautiful. Very funny is the play. My blog called Pole Position Force India and the web is www.polepositionforceindia.blogspot.com Bye bye!!

18/2/09 23:51

 
Blogger Force India said...

The Rigs of Rods 0.36 no work. error

18/2/09 23:52

 
Blogger docholiday said...

when i start the game i just get a message saying the side by side configuration is incorrect. whats that?

19/2/09 23:41

 
Blogger Kleyton said...

Pessoal parabens pelo simulador é exepcional nota 10 !

20/2/09 20:33

 
Blogger Chetic said...

I bet docholiday's problem is common for people using Vista.
Installing this should fix it:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=200b2fd9-ae1a-4a14-984d-389c36f85647

21/2/09 11:18

 
Blogger Lucas said...

Endlich ist die neue Version da!
Ich probier sie gleich aus...

Grüße aus Deutschland

21/2/09 18:07

 
Blogger TheMatt7000 said...

I have the same problem as (Will)

22/2/09 04:13

 
Blogger Will said...

I wonder if our problem hes something to do with the shaders? Hmmmmm...

Anyway, on another note. When I am finished installing the game, and I press "Configure and Play", nothing happens.

22/2/09 19:00

 
Blogger Jake271 said...

I know how to fix rigs of rods 0.36 problems go to http://www.microsoft.com/downloads/deatails.aspx.And turn off vegetation in configurator.That should fix it!

24/2/09 02:56

 
Blogger Jake said...

So is there or is there not collisions in multiplayer now? I'm confused... Because i've tried hooking onto another player with a crane and it didn't work no matter where i tried on the vehicle.

29/4/09 06:36

 
Blogger Cobi said...

i cant even open the game at all when i try to it says error 6

13/8/09 03:13

 
Blogger Nathan said...

Ive been trying for over 4 hours to try to get this game to work ive downloaded and installed it 12 times!!!! It says this aplication failed to start because the aplication configuration is incorrect.Re installing may fix this problem wich i did 100 times!!!! Someone do me a favor and help me out!!! >:<

3/7/10 02:30

 
Blogger Nathan said...

it would be a reilefe thanky you i really want this to work plz help me.

3/7/10 02:31

 
Blogger youwebaba said...

hi
with every version for rigs of rogs it just wont run
when ever i run it a window pops up and it says something about error 7
can any 1 help?
it will b helpful it you sent me a email on how to fix it:)
email: youwebaba@hotmail.ca

13/10/10 01:03

 

Post a Comment

<< Home