News and Updates on the Rigs of Rods truck simulator, based on an advanced soft-body physics engine.

Sunday, February 22, 2009

Bug fix: RoR 0.36.1

There was several bugs in the original release of 0.36 that mandated a bugfix release.
The main problems were:
  • The Visual Studio redistribuable included in the installer was of the wrong Service Pack version.
  • Some compilation flags added SSE instructions to the code, which are incompatible with older AMD processors, like the Duron.
  • The game crashed when vegetation was enabled.
  • There was visual glitches in some terrains and vehicles.
All these bugs should be gone with version 0.36.1.

Enjoy!

35 Comments:

Blogger Will said...

It still wont start for me. It say that there's something wrong with the configuration of the game, just like last time.

23/2/09 02:04

 
Blogger Lucas said...

Hmm...
Maybe Visual Studio isn't installed right.

I hope I can play the game now on my old AMD Athlon XP 2000+ , which doesn't support SSE

I'll test it as soon as i can...

23/2/09 09:28

 
Blogger Sean said...

thanks for the update, most appreciative

23/2/09 18:52

 
Blogger Waakku said...

Great! Now I go Error 7 before game even starts and config won't start eighter! d3dx9 40_dll missing. I don't like this at all! :/

23/2/09 20:33

 
Blogger kozlik-wiki said...

i have same problem like Waakku... http://wiki.rigsofrods.com/index.php?title=Error_7#DynLib::load

23/2/09 22:38

 
Blogger neoplan60 said...

Same problem for me - I've reinstalled it, deleted my old ror and downloaded the latest Directx and it still won't work! Am I doing something wrong, or will it not work on my computer?

My PC Specs are:

2.8ghz Intel p4, 2gb ram, ati radeon 4650 512mb, 80gb samsung hdd, win xp media center edition.

24/2/09 11:22

 
Blogger The Best Of Computer said...

same problem for me, I have installed on two different PC to test but does not go on both.then how to resolve?

24/2/09 21:35

 
Blogger Jake said...

I have the same problem as most of the other people here. I just downloaded and installed .36.1 and the configurator won't even start and when I just try to run the game, it says some .dll is missing or something like that. The first version of .36 worked just fine for me but now i guess the update screwed it up. It sucks cause i deleted my .36 setup without knowing .36.1 doesn't work. Hey, Pricorde, i'm all for the updates, but make sure they work next time!

25/2/09 06:49

 
Blogger Lucas said...

Just search the "d3dx9_40.dll" with google.
Download it and copy it to the Rigs Of Rods Directory in Program Files.

Then It will work fine (I had this problem too...)

25/2/09 15:17

 
Blogger Theresa said...

Hi, I've tried cut and pasting the "d3dx9_40.dll" from my windows system 32 directory into the ROR directory but still it wont run. The message I get says the "application configoration is incorrect" It's the same whether I run the game or the configorator.
Can anyone help?
Thanks on behalf of Diesel

27/2/09 12:43

 
Blogger Tin said...

I have this problem too. Can anyone help?

27/2/09 15:14

 
Blogger Lucas said...

Try to download the newest Visual c++ 2008 Runtime

28/2/09 19:28

 
Blogger Will said...

This comment has been removed by the author.

1/3/09 22:00

 
Blogger =Tristan= said...

This comment has been removed by the author.

6/3/09 02:38

 
Blogger =Tristan= said...

=D. Everything works now. I can load all of the maps and the error when somebody joins with the same vehicle crashes everyone is fixed to thank god. Too bad there is still the flexbody problem when you crash a car really badly and the screen goes black and everyone's sound breaks. All in all, good job. Also about the problem people are having, make sure the shortcuts are correct, when I installed this version, the game put the wrong directory in the "start in" path in the shortcut. Easy fix.

6/3/09 02:41

 
Blogger icemanwinhalo said...

I have the same problem as Will, but it worked in 0.36 now it doesn't work with 0.36.1 I will attempt to find out.

7/3/09 21:56

 
Blogger Gallaecio said...

Compiling on Kubuntu 9.04 64-bit failed at around 57%. Don't know if it's about missed dependencies or about my 64-bit feature, but I'll try to compile next version you release (whenever you do) and tell you.

Great work, anyway. And thanks for releasing source code.

16/3/09 08:32

 
Blogger jloup said...

Compilation doesn't work on Ubuntu 8.10 with cmake because rornet.h can't be found (used by network.h in the main directory for instance). this file doesn't exist, i tried to replace it by rornetv2.h, but couldn't get raknet compiled...

16/3/09 11:09

 
Blogger Thomas said...

please follow this guide:
http://wiki.rigsofrods.com/pages/Compiling_Sources

17/3/09 09:34

 
Blogger Joshua said...

Still waiting on the mac version

25/3/09 23:38

 
Blogger phil said...

I had the same issue (specifically, it couldn't find MSCVP90.dll and MSCVR90.dll).

Turns out it's an easy fix. Download and run the Visual C++ 2008 redistributable package direct from microsoft.com.

That will take care of the MSCV*90.dll errors.

If you have DirectX errors, make sure you have the latest version by running the DirectX web updater (also from microsoft.com).

You may need to use IE for that one. It wouldn't work in Firefox for me cos of the "Windows Genuine Advantage" nonsense.

Hope that helps someone. RoR continues to rock :)

19/4/09 20:52

 
Blogger Hapi said...

hello... hapi blogging... have a nice day! just visiting here....

6/5/09 05:30

 
Blogger File said...

Download Forum Poster V3 3.0 at FileAfro.com

http://www.fileafro.com/view_forum-poster-v3-30.html

6/5/09 06:00

 
Blogger Keyword said...

hello... you may submit this blog to my webBlog Directory, keyworddir.info.. have a nice day!

Keyword Directory

6/5/09 20:00

 
Blogger natasha said...

Watch Natsha Naked!

9/5/09 11:00

 
Blogger itchy8me said...

love this "game"!!, and indeed thanks for releasing the source code!

however cant compile on my ubuntu jaunty 64 bit.. get error:

make[2]: *** No rule to make target `/usr/lib/libOIS-1.2.0.so', needed by `dependencies/caelum/samples/caelumlab'. Stop.
make[1]: *** [dependencies/caelum/samples/CMakeFiles/caelumlab.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 66%] Built target hydrax
[ 69%] Built target RenderSystem_GL
make: *** [all] Error 2

11/5/09 16:49

 
Blogger dmaxboy08 said...

hey everyone i saw this game on youtube and it looks great to play but when i downloaded it i got a "application configuration error" i have been reading all of the posts but i couldnt find a solution to this problem. can anyone please help me?

27/10/09 03:22

 
Blogger pjhotgame said...

some one please help me i error 5!!

ERR_ITEM_NOT_FOUND
This page is about an error. Please help by adding your own experiences with this problem.
This error is thrown when a material (ie, a tracks/whatever) is not found. This error now occurs fequently in v0.35 because only active truck .zip files are opened. You may have dependancies in unopened .zip files. The RoR.log file will specify which material is missing.


OverlayElement::setMaterialName

The material being requested is not found. The mod you downloaded is incomplete. Ask the author for a complete one.

Another reason is that the map you are using uses LODs (Level Of Detail), and you have a non-updated version of RoR, which means that LODs cause Error 5. A fix for this is to go here: http://wsync-history.rigsofrods.com/0178/ and download the file 'rorconfig.exe', Then go to this link: http://wsync-history.rigsofrods.com/0169/ and download the file 'RoR.exe'. Then place them both into your Program Files directory of RoR (Usually C:\Program Files\Rigs Of Rods 0.36.2), and if Windows asks you to replace the old files, click 'Yes To All", then enable LODs in the Advanced tab of the Configurator.

3/11/09 13:42

 
Blogger Kukkuu said...

I'm totally unable to compile under Ubuntu Jaunty 32bit.I got to 79%, when I got

~/build/ror/build/0.36.3/build/dependencies/mygui/src/MyGUI_Guid.cpp:27:23: error: uuid/uuid.h: No such file or directory
~/build/ror/build/0.36.3/build/dependencies/mygui/src/MyGUI_Guid.cpp: In static member function ‘static MyGUI::Guid MyGUI::Guid::generate()’:
~/build/ror/build/0.36.3/build/dependencies/mygui/src/MyGUI_Guid.cpp:169: error: ‘uuid_generate’ was not declared in this scope
make[2]: *** [dependencies/mygui/CMakeFiles/mygui.dir/src/MyGUI_Guid.cpp.o] Error 1
make[1]: *** [dependencies/mygui/CMakeFiles/mygui.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX executable rorconfig
[ 79%] Built target rorconfig
make: *** [all] Error 2


It's a shame, really... But I guess it's work in progress, and I just need to be patient. Although I would appreciate a .deb that just works.

2/3/10 00:06

 
Blogger tdev said...

please try to compile the latest svn trunk. if you still experience this issue, please file a bug at http://redmine.rigsofrods.org/

thanks

2/3/10 03:02

 
Blogger Kukkuu said...

Thanks for the advice, but I managed to get it to work by upgrading to Ubuntu 9.10 and using the installer.

What's interesting is that the game seems to work better every time I run it. The first time it just gave me a black screen and eventually crashed. The second time I was able to play, but there was no sound. The third time I was also able to hear things.

It still segfaults from time to time, though... maybe I'll test some more and file a bug if I can find out what circumstances cause it to segfault.

2/3/10 11:04

 
Blogger best.love740 said...

:@:@ alot of problems:@:@

6/3/10 17:32

 
Blogger youwebaba said...

hi people
about rigs of rods error 7
i did every thing to make it run but it just wont
it says is the .dll file problem
i redownloaded all the dll files but it just wont run can any 1 help????????????!!!!!!!!!!!!

13/10/10 00:58

 
Blogger nsamele said...

can any one make me a thomas c2 school bus with working stop sign working stop lights stop arm and opening door that workes for 0.37.126

4/12/10 22:34

 
Blogger nsamele said...

i was wondering if anyone could make me a blue bird school bus. i would like it to be a flat nosed bus a flat bus. thank you .

4/12/10 22:37

 

Post a Comment

<< Home